lkml.org 
[lkml]   [2015]   [Jun]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] usb: move assignment out of if condition
From
Date
Hello.

On 6/30/2015 4:02 PM, Kris Borer wrote:

> Fix four occurrences of the checkpatch.pl error:

> ERROR: do not use assignment in if condition

> Signed-off-by: Kris Borer <kborer@gmail.com>
> ---
> drivers/usb/core/hcd.c | 13 ++++++++-----
> 1 file changed, 8 insertions(+), 5 deletions(-)

> diff --git a/drivers/usb/core/hcd.c b/drivers/usb/core/hcd.c
> index be5b207..e268c45 100644
> --- a/drivers/usb/core/hcd.c
> +++ b/drivers/usb/core/hcd.c
[...]
> @@ -2734,7 +2735,8 @@ int usb_add_hcd(struct usb_hcd *hcd,
> /* "reset" is misnamed; its role is now one-time init. the controller
> * should already have been reset (and boot firmware kicked off etc).
> */
> - if (hcd->driver->reset && (retval = hcd->driver->reset(hcd)) < 0) {
> + retval = hcd->driver->reset(hcd);
> + if (hcd->driver->reset && retval < 0) {

If hcd->driver->reset() is NULL, this change warrants a kernel oops.

[...]

WBR, Sergei



\
 
 \ /
  Last update: 2015-06-30 15:41    [W:0.037 / U:0.496 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site