lkml.org 
[lkml]   [2015]   [Jun]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectAw: [PATCH] tpm, tpm_crb: migrate to struct acpi_table_tpm2 and acpi_tpm2_control
Date
Hi
>Betreff: [PATCH] tpm, tpm_crb: migrate to struct acpi_table_tpm2 and acpi_tpm2_control
> Migrate to struct acpi_table_tpm2 and struct acpi_tpm2_control defined
> in include/acpi/actbl3.h from the internal structures.

I definitely do like the idea! Thanks for spotting this!

However one small remark
> -struct crb_control_area {
> - u32 req;
> - u32 sts;
> - u32 cancel;
> - u32 start;
> - u32 int_enable;
> - u32 int_sts;
> - u32 cmd_size;
> - u64 cmd_pa;
> - u32 rsp_size;
> - u64 rsp_pa;
> -} __packed;
> -
>
> - if (le32_to_cpu(ioread32(&priv->cca->sts)) & CRB_CA_STS_ERROR)
> + if (le32_to_cpu(ioread32(&priv->ctl->error)) & CRB_CA_STS_ERROR)
> return -EIO;

I know the fields are described in include/acpi/actbl3.h as
+struct acpi_tpm2_control {
+ u32 reserved;
+ u32 error;
+ u32 cancel;
+ u32 start;
+ u64 interrupt_control;
+ u32 command_size;
+ u64 command_address;
+ u32 response_size;
+ u64 response_address;
+};

but are the names there still correct? Isn't this information outdated?
The acpi spec refers to the MS spec which is not present anymore, and MS refers to the TCG -- and in the PTP your names are used.

---> We should update the ACPI header?
At least the naming for reserved and error.
What do you think?

Thanks,
Peter


\
 
 \ /
  Last update: 2015-06-02 16:21    [W:0.080 / U:0.704 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site