lkml.org 
[lkml]   [2015]   [Jun]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [RFC/INCOMPLETE 01/13] context_tracking: Add context_tracking_assert_state

* Andy Lutomirski <luto@kernel.org> wrote:

> This will let us sprinkle sanity checks around the kernel without
> making too much of a mess.
>
> Signed-off-by: Andy Lutomirski <luto@kernel.org>
> ---
> include/linux/context_tracking.h | 8 ++++++++
> 1 file changed, 8 insertions(+)
>
> diff --git a/include/linux/context_tracking.h b/include/linux/context_tracking.h
> index 2821838256b4..0fbea4b152e1 100644
> --- a/include/linux/context_tracking.h
> +++ b/include/linux/context_tracking.h
> @@ -57,6 +57,13 @@ static inline void context_tracking_task_switch(struct task_struct *prev,
> if (context_tracking_is_enabled())
> __context_tracking_task_switch(prev, next);
> }
> +
> +static inline void context_tracking_assert_state(enum ctx_state state)
> +{
> + rcu_lockdep_assert(!context_tracking_is_enabled() ||
> + this_cpu_read(context_tracking.state) == state,
> + "context tracking state was wrong");
> +}

Please don't introduce assert() style debug check interfaces!

(And RCU should be fixed too I suspect.)

They are absolutely horrible on the brain when mixed with WARN_ON() interfaces,
which are the dominant runtime check interface in the kernel.

Instead make it something like:

#define ct_state() (this_cpu_read(context_tracking.state))

#define CT_WARN_ON(cond) \
WARN_ON(context_tracking_is_enabled() && (cond))

and then the debug checks can be written as:

CT_WARN_ON(ct_state() != CONTEXT_KERNEL);

This is IMHO _far_ more readable than:

context_tracking_assert_state(CONTEXT_KERNEL);

ok?

(Assuming people will accept 'ct/CT' as an abbreviation for context tracking.)

Thanks,

Ingo


\
 
 \ /
  Last update: 2015-06-17 12:01    [W:0.407 / U:0.044 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site