lkml.org 
[lkml]   [2015]   [May]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v5 WIP 5/5] paride: use new parport device model
On Wed, May 20, 2015 at 10:07:48AM +0200, Jean Delvare wrote:
> Hi Sudip,
>
> On Wed, 6 May 2015 15:46:17 +0530, Sudip Mukherjee wrote:
> > modify paride driver to use the new parallel port device model.
>
> Leading capital please ;-)
yes, its the linux habit of writing in small letters. :)
>
> >
> > Signed-off-by: Sudip Mukherjee <sudip@vectorindia.org>
> > ---
> >
> > + }
> > + par_cb->flags = 0;
> > + par_cb->wakeup = pi_wake_up;
> > + par_cb->private = (void *)pi;
> > + pi->pardev = parport_register_dev_model(port, pi->device, par_cb,
> > + unit);
>
> If pi->device already includes the device number, and you are passing
> it again as unit, won't you end up with odd names like pcd0.0, pcd1.1,
> pcd2.2 etc?
yes, it is. This is the only driver using parport where in the probe
i had to use strncmp again.

>
> > parport_put_port(port);
> > + kfree(par_cb);
>
> If you don't need par_cb anywhere else then you shouldn't be allocating
> it dynamically. It's small enough to fit on the stack really.
like you suggested, I will make it local in all the drivers.

regards
sudip.
>
> --
> Jean Delvare
> SUSE L3 Support


\
 
 \ /
  Last update: 2015-05-20 11:21    [W:0.094 / U:0.540 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site