lkml.org 
[lkml]   [2015]   [Apr]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2] x86: Revert E820_PRAM change in e820_end_pfn()
On Tue, Apr 07, 2015 at 09:36:37AM +0300, Boaz Harrosh wrote:
> On 04/06/2015 10:00 PM, Toshi Kani wrote:
> > 'Commit ec776ef6bbe17 ("x86/mm: Add support for the non-standard
> > protected e820 type")' added E820_PRAM ranges, which do not have
> > have struct-page. Therefore, there is no need to update max_pfn
> > to cover the E820_PRAM ranges.
>
> But E820_PRAM ranges will have the possibility for struct-page.
>
> That said I have tested with this patch + struct-page and

I'd love to resurrect the old "real page backed" pmem support from
the old Intel patches eventually, but with all the arguments on
how we should do I/O on pmem I'd like to keep that a ѕeparate
discussion. And leaving only fragments of some support in is a bad
idea, so sorry for letting all this slip through..

> > -static unsigned long __init e820_end_pfn(unsigned long limit_pfn)
> > +static unsigned long __init e820_end_pfn(unsigned long limit_pfn, unsigned type)
>
> Why don't you rename it to say e820_max_ram_pfn or something with ram
> as you noted, and drop the @type. As Christoph said it is very ugly. You do not
> put an extra parameter because of a bad name?
>
> Anyway you are changing all call sites so it will not even be a bigger
> change

It's a static function, and we have much worse naming sins in public
ones, so I'm not worried about a _ram more or less. But if people feel
stronly about it I'm fine with adding the _ram.

I feel pretty stronly against adding back a pointless argument, though.


\
 
 \ /
  Last update: 2015-04-07 09:41    [W:0.029 / U:3.772 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site