lkml.org 
[lkml]   [2015]   [Apr]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 2/3 V2] time: allow gcc to fold constants when using
On Wed, 22 Apr 2015, Joe Perches wrote:

> On Wed, 2015-04-22 at 14:00 +0200, Thomas Gleixner wrote:
> > On Sun, 12 Apr 2015, Nicholas Mc Guire wrote:
> > > +extern unsigned long __msecs_to_jiffies(const unsigned int m);
> > > +#if HZ <= MSEC_PER_SEC && !(MSEC_PER_SEC % HZ)
> > > +static inline unsigned long _msecs_to_jiffies(const unsigned int m)
> > > +{
> >
> > This should move the comments explaining the logic for each variant as
> > well.
> []
> > It'd be nice to have this as two patches:
> >
> > 1) Factor out the code into inline helpers w/o adding anything
>
> It also might be nice to use a single static inline
> with #ifdef blocks inside that inline rather than
> have 3 separate static inline msecs_to_jiffies.

That was actually intentional to make it more readable - atleast
I thought its more readable this way than it
was before.

>
> > 2) Add the __builtin_constant_p() check
>
> And please add the usecs_to_jiffies variants in a
> similar patch set.
>
yup - as soon as its clean for msecs_to_jiffies applying
the same refactoring for usecs_to_jiffies is streight forward
so basically just waiting for the feedback on the
first one before pushing the usecs_to_jiffies case out.

thx!
hofrat


\
 
 \ /
  Last update: 2015-04-22 17:21    [W:0.044 / U:1.064 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site