lkml.org 
[lkml]   [2015]   [Apr]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectRe: [PATCH] drivers/tty/nozomi.c: rename CONFIG_MAGIC
Hi Peter,

On Sun, Apr 12, 2015 at 6:16 PM, Peter Hurley <peter@hurleysoftware.com> wrote:
> Hi Valentin,
>
> On 04/12/2015 10:56 AM, Valentin Rothberg wrote:
>> The CONFIG_ prefix is reserved for Kconfig options in Make and CPP
>> syntax. CONFIG_MAGIC is a file local CPP identifier so strip the prefix
>> to apply to Kconfig's naming convention.
>>
>> Signed-off-by: Valentin Rothberg <valentinrothberg@gmail.com>
>> ---
>> I found this issue with ./scripts/checkkconfigsymbols.py
>> ---
>> drivers/tty/nozomi.c | 6 +++---
>> 1 file changed, 3 insertions(+), 3 deletions(-)
>>
>> diff --git a/drivers/tty/nozomi.c b/drivers/tty/nozomi.c
>> index 74885af8c7bd..4a4775e81963 100644
>> --- a/drivers/tty/nozomi.c
>> +++ b/drivers/tty/nozomi.c
>> @@ -140,7 +140,7 @@ static int debug;
>> #define R_FCR 0x0000 /* Flow Control Register */
>> #define R_IER 0x0004 /* Interrupt Enable Register */
>>
>> -#define CONFIG_MAGIC 0xEFEFFEFE
>> +#define MAGIC 0xEFEFFEFE
> ^^^^^
> This is too general for a preprocessor symbol; how about
> NOZOMI_CONFIG_MAGIC?

Okay, sounds much better than ``MAGIC''. I will send a second version
of this patch.

Kind regards,
Valentin

> Regards,
> Peter Hurley
>
>> #define TOGGLE_VALID 0x0000
>>
>> /* Definition of interrupt tokens */
>> @@ -660,9 +660,9 @@ static int nozomi_read_config_table(struct nozomi *dc)
>> read_mem32((u32 *) &dc->config_table, dc->base_addr + 0,
>> sizeof(struct config_table));
>>
>> - if (dc->config_table.signature != CONFIG_MAGIC) {
>> + if (dc->config_table.signature != MAGIC) {
>> dev_err(&dc->pdev->dev, "ConfigTable Bad! 0x%08X != 0x%08X\n",
>> - dc->config_table.signature, CONFIG_MAGIC);
>> + dc->config_table.signature, MAGIC);
>> return 0;
>> }
>>
>>
>


\
 
 \ /
  Last update: 2015-04-12 19:01    [W:0.033 / U:3.848 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site