lkml.org 
[lkml]   [2015]   [Mar]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 03/32] arc: copy_thread(): rename 'arg' argument to 'kthread_arg'


On 25/03/15 13:47, Vineet Gupta wrote:
> On Friday 13 March 2015 11:35 PM, Alex Dowad wrote:
>> The 'arg' argument to copy_thread() is only ever used when forking a new
>> kernel thread. Hence, rename it to 'kthread_arg' for clarity (and consistency
>> with do_fork() and other arch-specific implementations of copy_thread()).
>>
>> Signed-off-by: Alex Dowad <alexinbeijing@gmail.com>
>> ---
>> arch/arc/kernel/process.c | 9 ++++++---
>> 1 file changed, 6 insertions(+), 3 deletions(-)
>>
>> diff --git a/arch/arc/kernel/process.c b/arch/arc/kernel/process.c
>> index fdd8971..cf366bd 100644
>> --- a/arch/arc/kernel/process.c
>> +++ b/arch/arc/kernel/process.c
>> @@ -49,7 +49,9 @@ void arch_cpu_idle(void)
>>
>> asmlinkage void ret_from_fork(void);
>>
>> -/* Layout of Child kernel mode stack as setup at the end of this function is
>> +/* Copy architecture-specific thread state
>> + *
>> + * Layout of Child kernel mode stack as setup at the end of this function is
>> *
>> * | ... |
>> * | ... |
>> @@ -81,7 +83,7 @@ asmlinkage void ret_from_fork(void);
>> * ------------------ <===== END of PAGE
>> */
>> int copy_thread(unsigned long clone_flags,
>> - unsigned long usp, unsigned long arg,
>> + unsigned long usp, unsigned long kthread_arg,
>> struct task_struct *p)
>> {
>> struct pt_regs *c_regs; /* child's pt_regs */
>> @@ -110,9 +112,10 @@ int copy_thread(unsigned long clone_flags,
>> childksp[1] = (unsigned long)ret_from_fork; /* blink */
>>
>> if (unlikely(p->flags & PF_KTHREAD)) {
>> + /* kernel thread */
> This seems extraneous given that PF_KTHREAD above check makes is obvious that this
> is a kernel thread.
>
>> memset(c_regs, 0, sizeof(struct pt_regs));
>>
>> - c_callee->r13 = arg; /* argument to kernel thread */
>> + c_callee->r13 = kthread_arg;
>> c_callee->r14 = usp; /* function */
>>
>> return 0;
> Applied to for-next after pruning the comment above.
Thank you. Is it too late for me to tweak the commit comment?


\
 
 \ /
  Last update: 2015-03-25 13:41    [W:1.630 / U:0.212 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site