lkml.org 
[lkml]   [2015]   [Nov]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] mm: get rid of __alloc_pages_high_priority
On Thu, 12 Nov 2015, mhocko@kernel.org wrote:

> From: Michal Hocko <mhocko@suse.com>
>
> __alloc_pages_high_priority doesn't do anything special other than it
> calls get_page_from_freelist and loops around GFP_NOFAIL allocation
> until it succeeds. It would be better if the first part was done in
> __alloc_pages_slowpath where we modify the zonelist because this would
> be easier to read and understand. And do the retry at the very same
> place because retrying without even attempting to do any reclaim is
> fragile because we are basically relying on somebody else to make the
> reclaim (be it the direct reclaim or OOM killer) for us. The caller
> might be holding resources (e.g. locks) which block other other
> reclaimers from making any progress for example.
>
> Remove the helper and open code it into its only user. We have to be
> careful about __GFP_NOFAIL allocations from the PF_MEMALLOC context
> even though this is a very bad idea to begin with because no progress
> can be gurateed at all. We shouldn't break the __GFP_NOFAIL semantic
> here though. It could be argued that this is essentially GFP_NOWAIT
> context which we do not support but PF_MEMALLOC is much harder to check
> for existing users because they might happen deep down the code path
> performed much later after setting the flag so we cannot really rule out
> there is no kernel path triggering this combination.
>
> Signed-off-by: Michal Hocko <mhocko@suse.com>
> ---
>
> Hi,
> I think that this is more a cleanup than any functional change. We
> are rarely screwed so much that __alloc_pages_high_priority would
> fail. Yet I think that __alloc_pages_high_priority is obscuring the
> overal intention more than it is helpful. Another motivation is to
> reduce wait_iff_congested call to a single one in the allocator. I plan
> to do other changes in that area and get rid of it altogether.

I think it's a combination of a cleanup (the inlining of
__alloc_pages_high_priority) and a functional change (no longer looping
infinitely around a get_page_from_freelist() call). I'd suggest doing the
inlining in one patch and then the reworking of __GFP_NOFAIL when
ALLOC_NO_WATERMARKS fails just so we could easily revert the latter if
necessary.


\
 
 \ /
  Last update: 2015-11-12 22:01    [W:0.059 / U:0.012 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site