lkml.org 
[lkml]   [2014]   [Sep]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2 0/3] Return codes cleanup
On Mon, Sep 29, 2014 at 08:40:06PM -0600, Azael Avalos wrote:
> Up for review.
>
> This series of patches are a cleanup to the Toshiba
> configuration interface return codes (unification),
> since we are now using both the HCI and the SCI, as
> well as changing the returned type of the HCI/SCI
> read/write functions from acpi_status to u32, since
> the "status" was never checked on most of the functions.
>
> Changes since v1:
> - Be a bit more verbose on patch 1 about the Toshiba
> configuration interface
> - Merged patches 3 and 4 into a same patch
>
> Azael Avalos (3):
> toshiba_acpi: Rename hci_raw to tci_raw
> toshiba_acpi: Unify return codes prefix from HCI/SCI to TOS
> toshiba_acpi: Change HCI/SCI functions return code type
>
> drivers/platform/x86/toshiba_acpi.c | 369 ++++++++++++++++++------------------
> 1 file changed, 183 insertions(+), 186 deletions(-)

Queued to the testing branch. As we are at rc7 for 3.17 at this point, and this is a
cleanup, it is going to have to wait for the 3.18 merge window.

--
Darren Hart
Intel Open Source Technology Center


\
 
 \ /
  Last update: 2014-09-30 23:21    [W:0.051 / U:2.024 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site