lkml.org 
[lkml]   [2014]   [Aug]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [RESEND][PATCH 07/10][SCSI]mpt2sas: Added Reply Descriptor Post Queue (RDPQ) Array support
From
On Tue, Aug 12, 2014 at 3:07 PM, Joe Perches <joe@perches.com> wrote:
> On Tue, 2014-08-12 at 14:54 +0530, Sreekanth Reddy wrote:
>> So, the proposal is to allocate memory independently for each
>> Reply Queue and pass down all of the addresses to the firmware.
>> Then the firmware will just take each address and program the value
>> into the correct register.
>
> trivial note:
>
>> diff --git a/drivers/scsi/mpt2sas/mpt2sas_base.c b/drivers/scsi/mpt2sas/mpt2sas_base.c
> []
>> @@ -1179,17 +1184,22 @@ static int
>> _base_config_dma_addressing(struct MPT2SAS_ADAPTER *ioc, struct pci_dev *pdev)
>> {
>> struct sysinfo s;
>> - char *desc = NULL;
>> + u64 consistent_dma_mask;
>> +
>> + if (dma_mask)
>> + consistent_dma_mask = DMA_BIT_MASK(64);
>> + else
>> + consistent_dma_mask = DMA_BIT_MASK(32);
>>
>> if (sizeof(dma_addr_t) > 4) {
>> const uint64_t required_mask =
>> dma_get_required_mask(&pdev->dev);
>> if ((required_mask > DMA_BIT_MASK(32)) && !pci_set_dma_mask(pdev,
>> DMA_BIT_MASK(64)) && !pci_set_consistent_dma_mask(pdev,
>> - DMA_BIT_MASK(64))) {
>> + consistent_dma_mask)) {
>
> This would be easier to read if the embedded functions
> within the if were on separate lines like:

Accepted. next time onwards I will take care of this.

>
> if ((required_mask > DMA_BIT_MASK(32)) &&
> !pci_set_dma_mask(pdev, DMA_BIT_MASK(64)) &&
> !pci_set_consistent_dma_mask(pdev, consistent_dma_mask)) {
>
>


\
 
 \ /
  Last update: 2014-08-12 12:21    [W:0.043 / U:0.192 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site