lkml.org 
[lkml]   [2014]   [Jun]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH] [RFC PATCH v2] power:reset: Add defer reset object to send board specific reset
From
Hi,

2014-06-15 17:09 GMT+08:00 Sebastian Reichel <sre@kernel.org>:
>
> I think this belongs to drivers/reset and not to drivers/power/reset.
> The drivers in drivers/power/reset are about board reboot / shutdown.
> This driver seems to be used for periphals.

Yes, this driver is for pherphials and I think it is reasonble
to placed it at drivers/reset. I'll moved it in next release.

> Alternatively you could do this via the duration. An infinite long
> reset signal basically means, that the line is never changed back.
>
> To give a few examples for the above comments:
>
> /* keep "gpx3 5" low for 5ms, change back to high afterwards */
> defer_reset_vbus {
> compatible = "defer-reset";
> reset-gpios = <&gpx3 5 GPIO_ACTIVE_LOW>;
> duration = <5>;
> };
>
> /* keep "gpx3 5" high for 5ms, change back to low afterwards */
> defer_reset_vbus {
> compatible = "defer-reset";
> reset-gpios = <&gpx3 5 GPIO_ACTIVE_HIGH>;
> duration = <5>;
> };
>
> /* keep "gpx3 5" low */
> defer_reset_vbus {
> compatible = "defer-reset";
> reset-gpios = <&gpx3 5 GPIO_ACTIVE_LOW>;
> duration = <0>;

These DT properties looks simpler and better: Use of GPIO_ACTIVE_HIGH
and GPIO_ACTIVE_LOW increase readability for HW/SW developer, use
of <0> to indicate holding the reset signal. I'll updated code according
on this. Thanks for your comments.

--
Best regards,
Houcheng Lin


\
 
 \ /
  Last update: 2014-06-18 15:41    [W:3.360 / U:0.008 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site