lkml.org 
[lkml]   [2014]   [Apr]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 2/2] mfd: sec-core: Update sec_pmic documentation
From
Date
On czw, 2014-04-17 at 09:32 +0100, Lee Jones wrote:
> > Update the documentation for sec_pmic state container structure to
> > reflect current code.
> >
> > Signed-off-by: Krzysztof Kozlowski <k.kozlowski@samsung.com>
> > ---
> > include/linux/mfd/samsung/core.h | 29 +++++++++++++++++------------
> > 1 file changed, 17 insertions(+), 12 deletions(-)
> >
> > diff --git a/include/linux/mfd/samsung/core.h b/include/linux/mfd/samsung/core.h
> > index 2633083262ea..1923fe026c01 100644
> > --- a/include/linux/mfd/samsung/core.h
> > +++ b/include/linux/mfd/samsung/core.h
> > @@ -24,18 +24,23 @@ enum sec_device_type {
> > };
> >
> > /**
> > - * struct sec_pmic_dev - s5m87xx master device for sub-drivers
> > - * @dev: master device of the chip (can be used to access platform data)
> > - * @pdata: pointer to private data used to pass platform data to child
> > - * @i2c: i2c client private data for regulator
> > - * @iolock: mutex for serializing io access
> > - * @irqlock: mutex for buslock
> > - * @irq_base: base IRQ number for sec-pmic, required for IRQs
> > - * @irq: generic IRQ number for s5m87xx
> > - * @ono: power onoff IRQ number for s5m87xx
> > - * @irq_masks_cur: currently active value
> > - * @irq_masks_cache: cached hardware value
> > - * @type: indicate which s5m87xx "variant" is used
> > + * struct sec_pmic_dev - s2m/s5m master device for sub-drivers
> > + * @dev: Master device of the chip (can be used to access
> > + * platform data)
>
> Please remove the part in ()'s.

OK

>
> a) There's no need for it - we know what's in 'struct device' and b)
> if 'struct platform_data' is removed from 'struct device' this comment
> will become incorrect. Easy maintainability and all that ...
>
> > + * @pdata: Platform data from DTS or board files
>
> s/from/populated with data from

OK

>
> > + * @regmap_pmic: Regmap associated with PMIC's I2C address
> > + * @i2c: I2C client of the main driver
> > + * @device_type: Type of device, matches enum sec_device_type
> > + * @irq_base: Base IRQ number for device, required for IRQs
>
> Is there any reason for not using IRQ Domains?

No, I have it in my TODO list.

>
> > + * @irq: Generic IRQ number for device
> > + * @irq_data: Runtime data structure for IRQ controller
> > + * @ono: Power onoff IRQ number for s5m87xx
>
> Perhaps consider a better name for this in a future patch.

Actually I couldn't find usage of it so I plan to do some cleanup and
get rid of it.

Thanks for review.

Best regards,
Krzysztof

>
> > + * @wakeup: Whether or not this is a wakeup device
> > + * @wtsr_smpl: Whether or not to enable in RTC driver the Watchdog
> > + * Timer Software Reset (registers set to default value
> > + * after PWRHOLD falling) and Sudden Momentary Power Loss
> > + * (PMIC will enter power on sequence after short drop in
> > + * VBATT voltage).
> > */
> > struct sec_pmic_dev {
> > struct device *dev;
>



\
 
 \ /
  Last update: 2014-04-18 10:21    [W:0.204 / U:0.236 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site