lkml.org 
[lkml]   [2014]   [Feb]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 2/3] x86/hash: swap parameters of crc32_u32()
>>> On 24.02.14 at 12:46, Daniel Borkmann <dborkman@redhat.com> wrote:
> On 02/24/2014 11:53 AM, Jan Beulich wrote:
>>>>> On 24.02.14 at 11:22, Daniel Borkmann <dborkman@redhat.com> wrote:
>>> On 02/24/2014 09:03 AM, Jan Beulich wrote:
>>>>>>> On 22.02.14 at 13:09, Daniel Borkmann <dborkman@redhat.com> wrote:
>>>>> On 02/21/2014 11:33 AM, Jan Beulich wrote:
>>>>>> ... to match its two callers (i.e. the alternative would have been to
>>>>>> swap the arguments at the call sites).
>>>>>>
>>>>>> Signed-off-by: Jan Beulich <jbeulich@suse.com>
>>>>>> Cc: Francesco Fusco <ffusco@redhat.com>
>>>>>> Cc: Daniel Borkmann <dborkman@redhat.com>
>>>>>> Cc: Thomas Graf <tgraf@redhat.com>
>>>>>> Cc: David S. Miller <davem@davemloft.net>
>>>>>> ---
>>>>>> arch/x86/lib/hash.c | 2 +-
>>>>>> 1 file changed, 1 insertion(+), 1 deletion(-)
>>>>>>
>>>>>> --- 3.14-rc3-x86-hash-crc32.orig/arch/x86/lib/hash.c
>>>>>> +++ 3.14-rc3-x86-hash-crc32/arch/x86/lib/hash.c
>>>>>> @@ -37,7 +37,7 @@
>>>>>> #include <asm/cpufeature.h>
>>>>>> #include <asm/hash.h>
>>>>>>
>>>>>> -static inline u32 crc32_u32(u32 crc, u32 val)
>>>>>> +static inline u32 crc32_u32(u32 val, u32 crc)
>>>>>> {
>>>>>> #ifdef CONFIG_AS_CRC32
>>>>>> asm ("crc32l %1,%0\n" : "+r" (crc) : "rm" (val));
>>>>>
>>>>> Can you elaborate?
>>>>>
>>>>> Sorry, I need to ask here (even if it's a stupid question ;)) if this
>>>>> change is safe to do; are referring to a cleanup or fixing a concrete
>>>>> bug? The code is a modified version of the DPDK hash which you can find
>>>>> in [1]. Arguments of the caller are in the correct order, afaik.
>>>>>
>>>>> [1] http://dpdk.org/browse/dpdk/tree/lib/librte_hash/rte_hash_crc.h
>>>>
>>>> Yes, that file appears to be correct:
>>>>
>>>> rte_hash_crc_4byte(uint32_t data, uint32_t init_val)
>>>>
>>>> as opposed to
>>>>
>>>> static inline u32 crc32_u32(u32 crc, u32 val)
>>>>
>>>> (quite obviously data <-> val and crc <-> init_val, supported
>>>> by the second argument in each caller being named "seed").
>>>
>>> If you want a more descriptive name, feel free to rename these vars,
>>> but check it yourself, it's not a bug as you claim; results are the
>>> same:
>>
>> Even if the results are the same (operands being symmetric?), check
>> the generated code for your version and the fixed up one: The crc32
>> instruction allows one of its operands to be in memory for a reason.
>
> I'm fine with that. But then, please reflect these details in your
> commit message.

Hmm, to me it says exactly that.

Jan



\
 
 \ /
  Last update: 2014-02-24 13:41    [W:1.251 / U:0.300 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site