lkml.org 
[lkml]   [2014]   [Feb]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v5 02/33] genirq: Add irq_alloc_reserved_desc()
On Mon, 17 Feb 2014, Yinghai Lu wrote:
> On Wed, Jan 22, 2014 at 4:03 PM, Thomas Gleixner <tglx@linutronix.de> wrote:
> >
> > There is a clear step by step approach to get this done proper:
> >
> > 1) Get rid of the existing misconception/misnomer of
> > irq_reserve_irqs().
> >
> > Make it explicit that this is dealing with legacy irq spaces. It's
> > not that hard as there are only two users in tree which are both
> > trivial to fix.
>
> Hi, Thomas,
>
> While going through the code for kill irq_reserve_irqs(), I found that
> there is irq_reserve_irq().
>
> in include/linux/irq.h
>
> static inline int irq_reserve_irq(unsigned int irq)
> {
> return irq_reserve_irqs(irq, 1);
> }
>
> it is called via kernel/irq/chip.c::irq_set_chip().
>
> /*
> * For !CONFIG_SPARSE_IRQ make the irq show up in
> * allocated_irqs. For the CONFIG_SPARSE_IRQ case, it is
> * already marked, and this call is harmless.
> */
> irq_reserve_irq(irq);
>
> There are tens of irq_set_chip... calling for arches that does not
> support SPARSE_IRQ yet, and they does not use irq_alloc_desc()
> anywhere.
>
> so how about change those irq_reserve_irq to irq_set_allocated_irqs() and
> leave them there?

As I said before irq_reserve_irq() is a misnomer and a
misconception. Of course this needs to be fixed as well.

And you cannot just blindly change it because !SPARSE can use the
allocation. We are not creating stupid corner cases just to support
your sloppyness. Its not rocket science to do it the right way.

That said, it might be worthwhile to get rid of the !SPARSE case
completely. That would probably make quite some stuff simpler.

Thanks,

tglx






\
 
 \ /
  Last update: 2014-02-22 11:41    [W:0.061 / U:5.280 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site