lkml.org 
[lkml]   [2014]   [Oct]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH] ocfs2: improve code readability
Date
code was getting confusing as the priority of both the
operators ! and & are same.
this change is done to just to improve the readability
of the code.

Signed-off-by: Sudip Mukherjee <sudip@vectorindia.org>
---

hi,
i hope this is the way Weiwei Wang has thought of the logic when giving that BUG_ON,
please discard this patch if this assumption was worng.


fs/ocfs2/namei.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/fs/ocfs2/namei.c b/fs/ocfs2/namei.c
index 62620ab..1a05574 100644
--- a/fs/ocfs2/namei.c
+++ b/fs/ocfs2/namei.c
@@ -2764,7 +2764,7 @@ int ocfs2_del_inode_from_orphan(struct ocfs2_super *osb,
goto bail_unlock_orphan;
}

- BUG_ON(!di->i_flags & cpu_to_le32(OCFS2_DIO_ORPHANED_FL));
+ BUG_ON(!(di->i_flags & cpu_to_le32(OCFS2_DIO_ORPHANED_FL)));

/* Only delete entry if OCFS2_ORPHANED_FL not set, or
* there are two entries added */
--
1.8.1.2


\
 
 \ /
  Last update: 2014-10-31 14:01    [W:0.018 / U:0.112 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site