lkml.org 
[lkml]   [2014]   [Oct]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 3.18] tiny: rename ENABLE_DEV_COREDUMP to ALLOW_DEV_COREDUMP
On Thu, Oct 30, 2014 at 10:00:35AM +0100, Johannes Berg wrote:
> From: Johannes Berg <johannes.berg@intel.com>
>
> The ENABLE_DEV_COREDUMP option is misleading as it implies that
> it gets the framework enabled, this isn't true it just allows it
> to get enabled if a driver needs it.
>
> Rename it to ALLOW_DEV_COREDUMP to better capture its semantics.
>
> Signed-off-by: Johannes Berg <johannes.berg@intel.com>

Seems reasonable. The original "DISABLE" was really "FORCE_DISABLE"
(even if used), and the inverse of "FORCE_DISABLE" is not "ENABLE", it's
"ALLOW" (if used).

Reviewed-by: Josh Triplett <josh@joshtriplett.org>

> drivers/base/Kconfig | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/base/Kconfig b/drivers/base/Kconfig
> index 99d30729d11e..e9f96afe920d 100644
> --- a/drivers/base/Kconfig
> +++ b/drivers/base/Kconfig
> @@ -171,8 +171,8 @@ config WANT_DEV_COREDUMP
> Drivers should "select" this option if they desire to use the
> device coredump mechanism.
>
> -config ENABLE_DEV_COREDUMP
> - bool "Enable device coredump" if EXPERT
> +config ALLOW_DEV_COREDUMP
> + bool "Allow device coredump" if EXPERT
> default y
> help
> This option controls if the device coredump mechanism is available or
> @@ -187,7 +187,7 @@ config ENABLE_DEV_COREDUMP
> config DEV_COREDUMP
> bool
> default y if WANT_DEV_COREDUMP
> - depends on ENABLE_DEV_COREDUMP
> + depends on ALLOW_DEV_COREDUMP
>
> config DEBUG_DRIVER
> bool "Driver Core verbose debug messages"
> --
> 2.1.0
>
>


\
 
 \ /
  Last update: 2014-10-30 15:01    [W:1.219 / U:0.004 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site