lkml.org 
[lkml]   [2014]   [Oct]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v6 0/7] staging: skein: CryptoAPI and Module Support
Greg,

On Fri, Oct 24, 2014 at 05:29:09PM -0500, Eric Rost wrote:
> Adds CryptoAPI and loadable module support to the Skein Hashing
> Algorithm. Collapses threefish module into skein module. Renames skein.c
> and skein.h to skein_base.c and skein_base.h so module can be named
> skein.ko. Inlines rotl_64 macro. Removes unneeded #define and
> skein_debug.h include.
>
> Eric Rost (7):
> staging: skein: Collapses threefish module
> staging: skein: Renames skein to skein_base
> staging: skein: Adds CryptoAPI Support
> staging: skein: Adds Loadable Module Support
> staging: skein: Inlines rotl_64
> staging: skein: Removes unneeded #define

For patches 1 through 6,

Reviewed-by: Jason Cooper <jason@lakedaemon.net>

We'll keep working on #7, but feel free to take the first six when you
get a moment Greg.

thx,

Jason.

> staging: skein: Removes skein_debug include
>
> drivers/staging/skein/Kconfig | 24 +--
> drivers/staging/skein/Makefile | 13 +-
> drivers/staging/skein/skein_api.h | 2 +-
> drivers/staging/skein/{skein.c => skein_base.c} | 5 +-
> drivers/staging/skein/{skein.h => skein_base.h} | 31 ++--
> drivers/staging/skein/skein_block.c | 2 +-
> drivers/staging/skein/skein_block.h | 2 +-
> drivers/staging/skein/skein_generic.c | 216 ++++++++++++++++++++++++
> drivers/staging/skein/skein_iv.h | 2 +-
> drivers/staging/skein/threefish_api.h | 2 +-
> 10 files changed, 249 insertions(+), 50 deletions(-)
> rename drivers/staging/skein/{skein.c => skein_base.c} (99%)
> rename drivers/staging/skein/{skein.h => skein_base.h} (95%)
> create mode 100644 drivers/staging/skein/skein_generic.c
>
> --
> 2.1.1
>


\
 
 \ /
  Last update: 2014-10-27 15:01    [W:0.408 / U:0.056 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site