lkml.org 
[lkml]   [2014]   [Oct]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] perf/powerpc: Cache the DWARF debug info
On Thu, Oct 23, 2014 at 10:37:24AM -0300, Arnaldo Carvalho de Melo wrote:
> Em Wed, Oct 22, 2014 at 10:46:59AM -0700, Sukadev Bhattiprolu escreveu:
> > Jiri Olsa [jolsa@redhat.com] wrote:
> > | > + goto out;
> > | > + }
> > | > + dso->dwfl = dwfl;
> > |
> > | so by this we get powerpc arch code sharing dw handle via dso object,
> > | but we have lot of generic code too ;-)
> >
> > Well, this applies to powerpc...
> >
> > |
> > | could you make this happen for unwind__get_entries.. probably
> > | both sharing same generic code I guess
> >
> > and unwind_get_entries() applies only to x86 and arm right ? ;-)
> > Or at least thats what the config/Makefile says.
>
> > I can take a look at unwind_get_entries(), but can you please merge
> > this fix for now, since the current performance is bad?
>
> Right, I think the way it is now is a good compromise, i.e. you seem to
> be using the right place to cache this, this is restricted to powerpc,
> i.e. if leaks or excessive memory usage happens in workloads with lots
> of DSOs having dwfl handlers open at the same times happens, it doesn't
> affect users in other arches.
>
> Jiri: do you agree?

well it's powerpc specific now.. anyway the code in the patch
to open the dwfl is generic and should be in in generic
place.. like in some extern function that the x86 would call
to get the dwfl handle

also the current patch leaks the dso->dwfl, which is never freed -> dwfl_end-ed,
dwfl_end should be called of in dso__delete I think

jirka


\
 
 \ /
  Last update: 2014-10-23 16:41    [W:0.054 / U:0.324 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site