lkml.org 
[lkml]   [2014]   [Oct]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH v5 09/12] Driver core: Unified interface for firmware node properties
Date
On Monday, October 20, 2014 04:19:57 PM Arnd Bergmann wrote:
> On Monday 20 October 2014 01:46:00 Rafael J. Wysocki wrote:
> >
> > > Something like:
> > >
> > > #define define_fwnode_accessors(__type, __devprop_type) \
> > > int device_property_read_##__type(struct device *dev, \
> > > const char *propname, __type *val) \
> > > { \
> > > if (IS_ENABLED(CONFIG_OF) && dev->of_node) \
> > > return of_property_read_##__type(dev->of_node, propname, val); \
> > > return acpi_dev_prop_read(ACPI_COMPANION(dev), propname, \
> > > __devprop_type, val); \
> > > } \
> > > int fwnode_property_read_##__type(struct fwnode_handle *fwnode, \
> > > const char *propname, __type *val) \
> > > { \
> > > if (IS_ENABLED(CONFIG_OF) && is_of_node(fwnode)) \
> > > return of_property_read_##__type(of_node(fwnode), propname, val); \
> > > else if (IS_ENABLED(CONFIG_ACPI) && is_acpi_node(fwnode)) \
> > > return acpi_dev_prop_read(acpi_node(fwnode), propname, \
> > > __devprop_type, val); \
> > > return -ENXIO; \
> > > }
> > >
> > > define_fwnode_accessors(u8, DEV_PROP_U8);
> > > define_fwnode_accessors(u16, DEV_PROP_U16);
> > > define_fwnode_accessors(u32, DEV_PROP_U32);
> > > define_fwnode_accessors(u64, DEV_PROP_U64);
> > >
> > > That significantly reduces the code size for these things.
> >
> > So I was considering to do that, but eventually decided not to, because (1)
> > adding kerneldoc comments to such things looks odd and (2) (which IMO is
> > more important) this breaks LXR (for example, the thing at lxr.free-electrons.com
> > that some people, including me in particular, occasionally use to check how things
> > are defined). And even if you used the old good grep to look for a definition of
> > fwnode_property_read_u8, say, this wouldn't work exactly as expected I'm afraid.
>
> Agreed, I'd also prefer your proposed code over Grant's macros.
>
> > I would very much like to retain the headers at least for this reason, if that's
> > not a big deal.
> >
> > What I can do, however, is to use macros for generating the bodies of those
> > functions.
>
> Yes, just don't do any concatenation to generate the names of the called
> functions, i.e.
>
> return fwnode_call(of_property_read_u32, acpi_dev_prop_read, DEV_PROP_U32, node, propname, val);
>
> is better than
>
> return fwnode_call(u32, DEV_PROP_U32, node, propname, val);
>
> because it's easier to understand the call chain.

There is one concatenation like that in the code I have today, but it was
already present in the $subject series, in the of_dev_prop_read_array macro
in patch #2 (and it actually makes sense to me).

Rafael



\
 
 \ /
  Last update: 2014-10-21 00:21    [W:0.079 / U:0.460 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site