lkml.org 
[lkml]   [2014]   [Oct]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [RFC][PATCH 1/4] regulator: Add helper function to get "poweroff-source" property
Adding the corresponding drivers and DT maintainers to the loop (parts 
of the kernel which use this property)

Le 01/10/2014 20:07, Mark Brown a écrit :
> On Tue, Sep 30, 2014 at 05:29:43PM +0000, Romain Perier wrote:
>
>> +/**
>> + * of_get_regulator_poweroff_source - Get poweroff-source for given device_node
>> + * @np: Pointer to the given device_node
>> + *
>> + * return true if present false otherwise
>> + */
>> +bool of_get_regulator_poweroff_source(const struct device_node *np)
>> +{
>> + return of_property_read_bool(np, "poweroff-source");
>> +}
>> +EXPORT_SYMBOL_GPL(of_get_regulator_poweroff_source);
> This isn't really a regulator specific thing - it's common for the
> actual implementation to be to simply cut power but it could be
> something that doesn't look like a regulator doing it like a system
> monitor. I'd rename this to something like is_system_poweroff_source().
>
> You probably also want to CC the DT maintainers on this and add some
> documentation of this as a standard property, not entirely sure where
> exactly but I'm sure the DT people could advise.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2014-10-02 20:21    [W:0.451 / U:0.008 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site