[lkml]   [2014]   [Jan]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 1/3] mm: vmscan: shrink_slab: rename max_pass -> freeable
On Fri, 17 Jan 2014, Vladimir Davydov wrote:

> The name `max_pass' is misleading, because this variable actually keeps
> the estimate number of freeable objects, not the maximal number of
> objects we can scan in this pass, which can be twice that. Rename it to
> reflect its actual meaning.
> Signed-off-by: Vladimir Davydov <>
> Cc: Andrew Morton <>
> Cc: Mel Gorman <>
> Cc: Michal Hocko <>
> Cc: Johannes Weiner <>
> Cc: Rik van Riel <>
> Cc: Dave Chinner <>
> Cc: Glauber Costa <>

This doesn't compile on linux-next:

mm/vmscan.c: In function ‘shrink_slab_node’:
mm/vmscan.c:300:23: error: ‘max_pass’ undeclared (first use in this function)
mm/vmscan.c:300:23: note: each undeclared identifier is reported only once for each function it appears in

because of b01fa2357bca ("mm: vmscan: shrink all slab objects if tight on
memory") from an author with a name remarkably similar to yours. Could
you rebase this series on top of your previous work that is already in
 \ /
  Last update: 2014-01-22 01:41    [W:0.137 / U:0.136 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site