lkml.org 
[lkml]   [2013]   [Aug]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: ZRAM 3.10.6 Buffer I/O error
Hello,

On Mon, Aug 12, 2013 at 07:39:46PM +0300, Thomas Backlund wrote:
> 12.08.2013 17:27, Jordi Pujol skrev:
> >Hello,
> >
> >zram shows an error when mounting a swap partition,
> >current version Linux kernel 3.10.6,
> >previous versions worked, I suppose that latest zram patches have some
> >problem,
> >
> >machine is an AMD64 dual core, 4GB RAM
> >
> >+ modprobe -qb zram num_devices=2
> >+ echo 104857600 > /sys/block/zram0/disksize
> >
> ># mkswap /dev/zram0
> >Setting up swapspace version 1, size = 102396 KiB
> >no label, UUID=6c249930-2ba0-46cf-a8c6-766481942b7d
> >
> ># pager /var/log/dmesg
> >(no more errors shown)
> >
> ># swapon /dev/zram0
> >
> ># pager /var/log/dmesg
> >...
> >[ 309.300479] Buffer I/O error on device zram0, logical block 25599
> >[ 309.300491] Buffer I/O error on device zram0, logical block 25599
> >[ 309.300514] Buffer I/O error on device zram0, logical block 25599
> >[ 345.205887] Adding 102396k swap on /dev/zram0. Priority:-2 extents:1
> >across:102396k SSFS
> >
> >full log files and the kernel source are stored in the address:
> >
> >http://livenet.selfip.com/ftp/debian/zram_3.10.6_IO_error/
> >
>
>
> I think this one should fix it and belongs in 3.10 stable too:

Very true. Let's Cc Greg, explicitely.

--
Kind regards,
Minchan Kim


\
 
 \ /
  Last update: 2013-08-13 04:01    [W:0.565 / U:0.372 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site