lkml.org 
[lkml]   [2013]   [May]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 5/5] drivers: net: usb: rtl8150: making the code a bit better looking
On Mon, 20 May 2013, Ben Hutchings wrote:

> [...]
> > @@ -771,12 +770,12 @@ static void rtl8150_disconnect(struct usb_interface *intf)
> > }
> >
> > static struct usb_driver rtl8150_driver = {
> > - .name = driver_name,
> > - .probe = rtl8150_probe,
> > - .disconnect = rtl8150_disconnect,
> > - .id_table = rtl8150_table,
> > - .suspend = rtl8150_suspend,
> > - .resume = rtl8150_resume,
> > + .name = driver_name,
> > + .probe = rtl8150_probe,
> > + .disconnect = rtl8150_disconnect,
> > + .id_table = rtl8150_table,
> > + .suspend = rtl8150_suspend,
> > + .resume = rtl8150_resume,
> > .disable_hub_initiated_lpm = 1,
> > };
>
> These looked better before. Lining up initialisers in a structure
> definition is good style.

It is. This is what i usually do. However, scripts/Lindent is messed up
in (not only) this regard. IMHO it should not be used as it is.

I thought using what is recommended (at least in the documentation) makes
me a good citizen even though i don't like the end result much.

Again, the above is true in case i've not misunderstood something,
somewhere.


Petko


\
 
 \ /
  Last update: 2013-05-20 21:41    [W:0.035 / U:0.080 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site