lkml.org 
[lkml]   [2013]   [May]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH] gpio: mcp23s08: Fix build error when CONFIG_SPI_MASTER=y && CONFIG_I2C=m
From
On Sun, May 19, 2013 at 9:10 AM, Axel Lin <axel.lin@ingics.com> wrote:
> This patch fixes below build error when CONFIG_SPI_MASTER=y && CONFIG_I2C=m &&
> CONFIG_GPIO_MCP23S08=y.

> When CONFIG_I2C=m, meaning we can't build the drivers in with I2C support.
> Thus don't allow the drivers to be compiled as built-in when CONFIG_I2C=m.

> --- a/drivers/gpio/Kconfig
> +++ b/drivers/gpio/Kconfig
> @@ -636,7 +636,7 @@ config GPIO_MAX7301
>
> config GPIO_MCP23S08
> tristate "Microchip MCP23xxx I/O expander"
> - depends on SPI_MASTER || I2C
> + depends on (SPI_MASTER && I2C!=m) || I2C

For me it looks like the result of the following will be the same
depends on (SPI_MASTER && !I2C) || I2C

--
With Best Regards,
Andy Shevchenko


\
 
 \ /
  Last update: 2013-05-19 10:21    [W:0.076 / U:0.204 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site