lkml.org 
[lkml]   [2013]   [May]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: 3.9 breaks EFI boot on E350
From
On Fri, May 17, 2013 at 2:43 AM, Christian König
<christian.koenig@amd.com> wrote:
> Am 16.05.2013 17:42, schrieb Yinghai Lu:
>
>> On Thu, May 16, 2013 at 8:23 AM, Christian König
>> <christian.koenig@amd.com> wrote:
>>>
>>> Am 16.05.2013 17:17, schrieb Yinghai Lu:
>>>
>>>> On Thu, May 16, 2013 at 5:49 AM, Christian König
>>>> <christian.koenig@amd.com> wrote:
>>>>>
>>>>> Am 16.05.2013 11:41, schrieb Christian König:
>>>>>
>>>>> Ups, the board DOES have a serial port, and I've got a log now that
>>>>> shows
>>>>> the mentioned patch above isn't the root cause.
>>>>>
>>>>> After commit 8d57470d8f859635deffe3919d7d4867b488b85a it indeed crashes
>>>>> very
>>>>> early in the boot sequence, but commit
>>>>> 98e7a989979b185f49e86ddaed2ad6890299d9f0 fixes that and now it crashes
>>>>> while
>>>>> trying to unpack the initrd with a completely different backtrace.
>>>>>
>>>> ok, did you post the boot log for that failing boot ?
>>>
>>>
>>> Yes, the bootlog is attached, but I also send it as "3.9 breaks EFI boot
>>> on
>>> E350 v2" to LKML with a request for help.
>>
>> can you boot with appending with "memtest"?
>
>
> Sure, bootlog with memtest is attached.

Please check attached patch, it should fix the problem.

Thanks

Yinghai
[unhandled content-type:application/octet-stream]
\
 
 \ /
  Last update: 2013-05-17 20:21    [W:0.393 / U:0.068 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site