lkml.org 
[lkml]   [2013]   [Mar]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: Uhhuh. NMI received for unknown reason 2c on CPU 0.
From
Date
On Tue, 2013-03-05 at 10:58 +0100, Borislav Petkov wrote:
> On Tue, Mar 05, 2013 at 10:42:17AM +0100, Jiri Slaby wrote:
> > On 03/05/2013 01:16 AM, Bjorn Helgaas wrote:
> > > [+cc e1000-devel, Jeff, Bruce]
> > >
> > > On Mon, Mar 4, 2013 at 2:50 PM, Borislav Petkov <bp@alien8.de> wrote:
> > >> On Fri, Feb 15, 2013 at 10:16:41AM +0100, Borislav Petkov wrote:
> > >>> So it looks Bjorn has taken most of them and the e1000e one will go
> > >>> through the e1000e maintainers. I'll test after the merge window is
> > >>> done.
> > >>
> > >> Issue still persists on 3.9-rc1 :-( :
> > >>
> > >> Mar 4 21:47:34 nazgul vmunix: [ 3223.412541] e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: Rx/Tx
> > >> Mar 4 21:47:34 nazgul vmunix: [ 3223.412554] e1000e 0000:00:19.0 eth0: 10/100 speed: disabling TSO
> > >> Mar 4 21:47:35 nazgul vmunix: [ 3224.034158] Uhhuh. NMI received for unknown reason 2c on CPU 0.
> > >> Mar 4 21:47:35 nazgul vmunix: [ 3224.034166] Do you have a strange power saving mode enabled?
> > >> Mar 4 21:47:35 nazgul vmunix: [ 3224.034168] Dazed and confused, but trying to continue
> > >
> > > The e1000e changes didn't get merged, did they? I don't see the
> > > following changes mentioned at https://lkml.org/lkml/2013/2/4/185 in
> > > 3.9-rc1:
> > >
> > > e1000e: fix pci-device enable-counter balance
> > > e1000e: fix runtime power management transitions
> > > e1000e: fix accessing to suspended device
> >
> > You're right. They are not even in -next :(.
>
> Oh, and there's another issue with this driver I reported yesterday:
> http://marc.info/?l=linux-kernel&m=136243374114892&w=2:
>
> "Trying to free already-free IRQ 20"
>
> which happens during suspend so it seems also related.
>
> Rafael, what's the state of those patches here:
> https://lkml.org/lkml/2013/2/4/185, are they ready to be tested or you
> still have issues with them?

They are in my queue of e1000e patches for net and are being testing
currently. I should be able to push them upstream this week.
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2013-03-05 11:21    [W:0.243 / U:0.040 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site