lkml.org 
[lkml]   [2013]   [Mar]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 04/10] mm: vmscan: Decide whether to compact the pgdat based on reclaim progress
On Thu 21-03-13 15:47:31, Mel Gorman wrote:
> On Thu, Mar 21, 2013 at 04:32:31PM +0100, Michal Hocko wrote:
> > On Sun 17-03-13 13:04:10, Mel Gorman wrote:
> > > In the past, kswapd makes a decision on whether to compact memory after the
> > > pgdat was considered balanced. This more or less worked but it is late to
> > > make such a decision and does not fit well now that kswapd makes a decision
> > > whether to exit the zone scanning loop depending on reclaim progress.
> > >
> > > This patch will compact a pgdat if at least the requested number of pages
> > > were reclaimed from unbalanced zones for a given priority. If any zone is
> > > currently balanced, kswapd will not call compaction as it is expected the
> > > necessary pages are already available.
> > >
> > > Signed-off-by: Mel Gorman <mgorman@suse.de>
> > > ---
> > > mm/vmscan.c | 52 +++++++++++++++++++++-------------------------------
> > > 1 file changed, 21 insertions(+), 31 deletions(-)
> > >
> > > diff --git a/mm/vmscan.c b/mm/vmscan.c
> > > index 279d0c2..7513bd1 100644
> > > --- a/mm/vmscan.c
> > > +++ b/mm/vmscan.c
> > > @@ -2694,8 +2694,11 @@ static unsigned long balance_pgdat(pg_data_t *pgdat, int order,
> > >
> > > do {
> > > unsigned long lru_pages = 0;
> > > + unsigned long nr_to_reclaim = 0;
> > > unsigned long nr_reclaimed = sc.nr_reclaimed;
> > > + unsigned long this_reclaimed;
> > > bool raise_priority = true;
> > > + bool pgdat_needs_compaction = true;
> >
> > I am confused. We don't want to compact for order == 0, do we?
> >
>
> No, but an order check is made later which I felt it was clearer. You are
> the second person to bring it up so I'll base the initialisation on order.

Dohh. Yes compact_pgdat is called only if order != 0. I was so focused
on pgdat_needs_compaction that I've missed it. Both checks use (order &&
pgdat_needs_compaction) so initialization based on order would be
probably better for readability.
--
Michal Hocko
SUSE Labs


\
 
 \ /
  Last update: 2013-03-21 17:41    [W:0.302 / U:0.036 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site