lkml.org 
[lkml]   [2013]   [Mar]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 1/4] posix_cpu_timer: Consolidate expiry time type
On Fri, 15 Mar 2013 17:53:59 +0100 Frederic Weisbecker <fweisbec@gmail.com> wrote:

> The posix cpu timer expiry time is stored in a union of
> two types: a 64 bits field if we rely on scheduler precise
> accounting, or a cputime_t if we rely on jiffies.
>
> This result in quite some duplicate code and special cases
> to handle the two types.
>
> Just unify this into a single 64 bits field. cputime_t can
> always fit into it.
>

x86_64 allnoconfig:

kernel/posix-cpu-timers.c: In function 'posix_cpu_timer_schedule':
kernel/posix-cpu-timers.c:1127: warning: 'now' may be used uninitialized in this function

It looks like it's always been buggy, but your switch from `union
cou_time_count' to `unsigned long long' made gcc notice it.



\
 
 \ /
  Last update: 2013-03-20 00:01    [W:0.065 / U:0.544 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site