lkml.org 
[lkml]   [2013]   [Feb]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 01/13] workqueue: remove WORK_CPU_NONE
Hello, Lai.

On Fri, Feb 01, 2013 at 02:41:24AM +0800, Lai Jiangshan wrote:
> In __next_wq_cpu() for_each_*wq_cpu(), the name WORK_CPU_LAST
> is proper than WORK_CPU_NONE, convert them to WORK_CPU_LAST.
>
> WORK_CPU_NONE is not used any more, just remove it.
...
> #define for_each_wq_cpu(cpu) \
> for ((cpu) = __next_wq_cpu(-1, cpu_possible_mask, 3); \
> - (cpu) < WORK_CPU_NONE; \
> + (cpu) < WORK_CPU_LAST; \
> (cpu) = __next_wq_cpu((cpu), cpu_possible_mask, 3))

LAST implies that it's the last element of the range and thus that
it's an inclusive range. Maybe we should rename it to WORK_CPU_END?

Thanks.

--
tejun


\
 
 \ /
  Last update: 2013-02-04 22:03    [W:1.208 / U:0.036 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site