lkml.org 
[lkml]   [2013]   [Feb]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH 2/2] tg3: Use different macros for pci_chip_rev_id accesses
From
From: "Michael Chan" <mchan@broadcom.com>
Date: Sat, 16 Feb 2013 14:09:45 -0800

> On Sat, 2013-02-16 at 13:20 -0800, Joe Perches wrote:
>> Upper case macros for various chip attributes are slightly
>> difficult to read and are a bit out of characterto the other
>> tg3_<foo> attribute functions.
>>
>> Convert:
>>
>> GET_ASIC_REV(tp->pci_chip_rev_id) -> tg3_asic_rev(tp)
>> GET_CHIP_REV(tp->pci_chip_rev_id) -> tg3_chip_rev(tp)
>>
>> Remove:
>> GET_METAL_REV(tp->pci_chip_rev_id) -> tg3_metal_rev(tp) (unused)
>>
>> Add:
>> tg3_chip_rev_id(tp) for tp->pci_chip_rev_id so access styles
>> are similar to tg3_asic_rev and tg3_chip_rev.
>>
>> These macros are not converted to static inline functions
>> because gcc (tested with 4.7.2) is currently unable to
>> optimize the object code it produces the same way and code
>> is otherwise larger.
>>
>> Signed-off-by: Joe Perches <joe@perches.com>
>
> Acked-by: Michael Chan <mchan@broadcom.com>

Applied.


\
 
 \ /
  Last update: 2013-02-18 19:21    [W:0.027 / U:0.268 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site