lkml.org 
[lkml]   [2013]   [Feb]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] ia64: rename cache_show to topology_cache_show
On Sun 17-02-13 09:36:49, Wu Fengguang wrote:
> On Sat, Feb 16, 2013 at 01:18:53PM +0100, Michal Hocko wrote:
> > On Fri 15-02-13 14:46:29, Andrew Morton wrote:
> > > On Fri, 15 Feb 2013 13:38:24 +0100
> > > Michal Hocko <mhocko@suse.cz> wrote:
> > >
> > > > Fenguang Wu has reported the following compile time issue
> > > > arch/ia64/kernel/topology.c:278:16: error: conflicting types for 'cache_show'
> > > > include/linux/slab.h:224:5: note: previous declaration of 'cache_show' was here
> > > >
> > > > which has been introduced by 749c5415 (memcg: aggregate memcg cache
> > > > values in slabinfo). Let's rename ia64 local function to prevent from
> > > > the name conflict.
> > >
> > > Confused. Tony fixed this ages ago?
> >
> > Yes but it was after 3.7 so I didn't have it in my tree and I found out
> > only after I sent this email. Sorry about the confusion.
>
> Michal, sorry about the confusions. Does this indicate anything
> improveable in the build test/notification?

No, the message was clear. I should have checked Linus's tree before
posting the fix.

--
Michal Hocko
SUSE Labs


\
 
 \ /
  Last update: 2013-02-17 11:21    [W:0.036 / U:2.052 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site