[lkml]   [2013]   [Feb]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [PATCH 6/9] gpiolib: use descriptors internally
    On Sat, Feb 9, 2013 at 10:17 AM, Grant Likely <> wrote:

    > The ERR_PTR()/IS_ERR() is a horrible pattern for code
    > readability because it breaks the expectations that programmers have for
    > what is and is not a bad pointer. There are decades of history where the
    > test for a bad pointer is 'if (!ptr)'. Not only does ERR_PTR make make
    > that test not work, but the compiler won't tell you when you get it
    > wrong.
    > There are places where ERR_PTR makes sense. Particularly when
    > communicating with userspace where error codes have very specific
    > meanings, but I don't want it in the GPIO subsystem.

    OK I disagree but you get to decide.

    However if you take this all the way to the descriptor API
    it will make the consumer (driver) API for GPIO descriptors deviate
    from what is today used for clocks, regulators and pins.

    With all the resulting confusion for users.
    I've seen worse subsystem deviations though.

    Linus Walleij

     \ /
      Last update: 2013-02-11 15:21    [W:3.060 / U:0.212 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site