lkml.org 
[lkml]   [2013]   [Dec]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
Subject[PATCH v2] drivers: scsi: scsi_lib.c: use SG_POOL instead of SP
the macro SP is too common to make conflict with others, so recommend
to use another more readable and non-conflict macro SG_POOL instead of
(and recommend others do not use SP either).

The related warning (with allmodconfig for hexagon):

CC [M] drivers/scsi/scsi_lib.o
drivers/scsi/scsi_lib.c:46:0: warning: "SP" redefined [enabled by default]
arch/hexagon/include/uapi/asm/registers.h:9:0: note: this is the location of the previous definition


Signed-off-by: Chen Gang <gang.chen.5i5j@gmail.com>
---
drivers/scsi/scsi_lib.c | 16 ++++++++--------
1 files changed, 8 insertions(+), 8 deletions(-)

diff --git a/drivers/scsi/scsi_lib.c b/drivers/scsi/scsi_lib.c
index 7bd7f0d..19967fa 100644
--- a/drivers/scsi/scsi_lib.c
+++ b/drivers/scsi/scsi_lib.c
@@ -43,28 +43,28 @@ struct scsi_host_sg_pool {
mempool_t *pool;
};

-#define SP(x) { x, "sgpool-" __stringify(x) }
+#define SG_POOL(x) { x, "sgpool-" __stringify(x) }
#if (SCSI_MAX_SG_SEGMENTS < 32)
#error SCSI_MAX_SG_SEGMENTS is too small (must be 32 or greater)
#endif
static struct scsi_host_sg_pool scsi_sg_pools[] = {
- SP(8),
- SP(16),
+ SG_POOL(8),
+ SG_POOL(16),
#if (SCSI_MAX_SG_SEGMENTS > 32)
- SP(32),
+ SG_POOL(32),
#if (SCSI_MAX_SG_SEGMENTS > 64)
- SP(64),
+ SG_POOL(64),
#if (SCSI_MAX_SG_SEGMENTS > 128)
- SP(128),
+ SG_POOL(128),
#if (SCSI_MAX_SG_SEGMENTS > 256)
#error SCSI_MAX_SG_SEGMENTS is too large (256 MAX)
#endif
#endif
#endif
#endif
- SP(SCSI_MAX_SG_SEGMENTS)
+ SG_POOL(SCSI_MAX_SG_SEGMENTS)
};
-#undef SP
+#undef SG_POOL

struct kmem_cache *scsi_sdb_cache;

--
1.7.7.6

\
 
 \ /
  Last update: 2013-12-04 04:01    [W:0.604 / U:0.076 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site