[lkml]   [2013]   [Dec]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 1/6] kernfs: s/sysfs_dirent/kernfs_node/ and rename its friends accordingly
On Wed, Dec 11, 2013 at 02:11:53PM -0500, Tejun Heo wrote:
> kernfs has just been separated out from sysfs and we're already in
> full conflict mode. Nothing can make the situation any worse. Let's
> take the chance to name things properly.
> This patch performs the following renames.
> * s/sysfs_elem_dir/kernfs_elem_dir/
> * s/sysfs_elem_symlink/kernfs_elem_symlink/
> * s/sysfs_elem_attr/kernfs_elem_file/
> * s/sysfs_dirent/kernfs_node/
> * s/sd/kn/ in kernfs proper
> * s/parent_sd/parent/
> * s/target_sd/target/
> * s/dir_sd/parent/
> * s/to_sysfs_dirent()/rb_to_kn()/
> * misc renames of local vars when they conflict with the above
> Because md, mic and gpio dig into sysfs details, this patch ends up
> modifying them. All are sysfs_dirent renames and trivial. While we
> can avoid these by introducing a dummy wrapping struct sysfs_dirent
> around kernfs_node, given the limited usage outside kernfs and sysfs
> proper, I don't think such workaround is called for.

Ugh, why are those drivers digging into sysfs core bits anyway? I'll
look and see if they should be fixed up as well, as I really doubt a
"normal" driver should ever care about this type of thing...


greg k-h

 \ /
  Last update: 2013-12-12 03:21    [W:0.665 / U:2.188 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site