lkml.org 
[lkml]   [2013]   [Nov]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    SubjectRe: [PATCH net-next 13/13] scripts/checkpatch.pl: Add dev_kfree_skb*(NULL) check to checkpatch
    From
    Date
    On Sat, 2013-11-02 at 19:17 +0530, Govindarajulu Varadarajan wrote:
    > Signed-off-by: Govindarajulu Varadarajan <govindarajulu90@gmail.com>
    []
    > diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl
    []
    > @@ -3719,7 +3719,7 @@ sub process {
    > # check for needless "if (<foo>) fn(<foo>)" uses
    > if ($prevline =~ /\bif\s*\(\s*($Lval)\s*\)/) {
    > my $expr = '\s*\(\s*' . quotemeta($1) . '\s*\)\s*;';
    > - if ($line =~ /\b(kfree|usb_free_urb|debugfs_remove(?:_recursive)?)$expr/) {
    > + if ($line =~ /\b(kfree|dev_kfree_skb|dev_kfree_skb_any|dev_kfree_skb_irq|usb_free_urb|debugfs_remove(?:_recursive)?)$expr/) {
    > WARN('NEEDLESS_IF',
    > "$1(NULL) is safe this check is probably not required\n" . $hereprev);
    > }

    OK, but I think this is easier to read as

    dev_kfree_skb(?:_skb|_any|_irq)?




    \
     
     \ /
      Last update: 2013-11-04 16:01    [W:6.117 / U:0.088 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site