[lkml]   [2013]   [Nov]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: VT-d and x2apic: broken resume after suspend to ram
On Fri, Nov 01, 2013 at 02:21:07PM +0100, Peter Senna Tschudin wrote:
> On Fri, Nov 1, 2013 at 2:07 PM, Joerg Roedel <> wrote:
> > Which kernels have you tried? Does it happen with all of them or is
> > there a kernel-version where this started?
> I'm using 3.11.6-200.fc19.x86_64. I always had VT-d enabled, and
> suspend / resume never worked on Linux. I did not know that disabling
> VT-d could be a workaround to the resume issue until yesterday.
> Does this have anything in common to:

This is probably not related. As far as I can see this issue was about
boot problem with discrete graphics while your problem is related to

The next thing I would try on your machine is to get some kernel debug
messages from resume. This might be hard to get, since your notebook
has probably no serial port. But you can try to boot with
no_console_suspend on the kernel cmdline and see if it gives you any
output on resume.

Maybe some of the VT-d guys can take a look too?


 \ /
  Last update: 2013-11-01 16:01    [W:0.175 / U:0.732 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site