lkml.org 
[lkml]   [2013]   [Oct]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH V2 03/14] perf script: Make perf_script a local variable
On 10/22/13 8:34 AM, Adrian Hunter wrote:
> -static int __cmd_script(struct perf_session *session)
> +static int __cmd_script(struct perf_script *scr)

for naming consistency that should be *script.

> {
> int ret;
>
> signal(SIGINT, sig_handler);
>
> - ret = perf_session__process_events(session, &perf_script);
> + ret = perf_session__process_events(scr->session, &scr->tool);
>
> if (debug_mode)
> pr_err("Misordered timestamps: %" PRIu64 "\n", nr_unordered);
> @@ -1273,6 +1264,21 @@ int cmd_script(int argc, const char **argv, const char *prefix __maybe_unused)
> char *script_path = NULL;
> const char **__argv;
> int i, j, err;
> + struct perf_script perf_script = {

Ditto: struct perf_script script;


Otherwise the change looks fine to me.

Acked-by: David Ahern <dsahern@gmail.com>



\
 
 \ /
  Last update: 2013-10-23 08:21    [W:0.246 / U:0.328 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site