[lkml]   [2013]   [Jan]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH -v2 09/26] infiniband: rename random32() to prandom_u32()
On 1/5/2013 7:37 AM, Akinobu Mita wrote:
> 2013/1/5 Steve Wise <>:
>> I'm asking: why are you bothering with renaming the functions? This seems
>> like a needless change, _unless_ there are really non-pseudo-random services
>> being added.
> We already have get_random_byte() which is not pseudo-random number
> generator.
> Apart from that, the naming scheme was confusing without "prandom" prefix.
> Because I introduced new functions in the commit 6582c665 ("prandom:
> introduce prandom_bytes() and prandom_bytes_state()").

Ok, thanks for the explanation.

 \ /
  Last update: 2013-01-06 01:21    [W:0.077 / U:0.036 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site