lkml.org 
[lkml]   [2013]   [Jan]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 4/4] pinctrl/abx500: add AB8500 pinctrl driver
On 01/15/2013 02:43 AM, Linus Walleij wrote:
> From: Patrice Chotard <patrice.chotard@st.com>
>
> This adds a subdriver for the AB8500 pinctrl portions.

> diff --git a/drivers/pinctrl/pinctrl-ab8500.c b/drivers/pinctrl/pinctrl-ab8500.c

> +static struct abx500_pinctrl_soc_data ab8500_ranges_soc = {
> + .gpio_ranges = ab8500_pinranges,
> + .gpio_num_ranges = ARRAY_SIZE(ab8500_pinranges),
> + .pins = ab8500_ranges_pins,
> + .npins = ARRAY_SIZE(ab8500_ranges_pins),
> + .functions = ab8500_ranges_functions,
> + .nfunctions = ARRAY_SIZE(ab8500_ranges_functions),
> + .groups = ab8500_ranges_groups,
> + .ngroups = ARRAY_SIZE(ab8500_ranges_groups),
> + .alternate_functions = ab8500_alternate_functions,
> + .gpio_irq_cluster = ab8500_gpio_irq_cluster,
> + .ngpio_irq_cluster = ARRAY_SIZE(ab8500_gpio_irq_cluster),
> + .irq_gpio_rising_offset = AB8500_INT_GPIO6R,
> + .irq_gpio_falling_offset = AB8500_INT_GPIO6F,
> + .irq_gpio_factor = 1,
> +};
> +
> +void __devinit
> +abx500_pinctrl_ab8500_init(struct abx500_pinctrl_soc_data **soc)
> +{
> + *soc = &ab8500_ranges_soc;
> +}

"ranges" in that variable name seems a little odd since it's much more
than ranges... But otherwise, this patch, very briefly,

Reviewed-by: Stephen Warren <swarren@nvidia.com>




\
 
 \ /
  Last update: 2013-01-15 19:41    [W:0.080 / U:0.344 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site