lkml.org 
[lkml]   [2012]   [Jul]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH 33/36] AArch64: Generic timers support
From
I'm reviewing the only patch I really understand...

2012/7/6 Catalin Marinas <catalin.marinas@arm.com>:

> +/* This isn't really used any more */
> +#define CLOCK_TICK_RATE 1000

Is it still necessary to even have it there?

> + /* Try to determine the frequency from the device tree or CNTFRQ */
> + if (!of_property_read_u32(np, "clock-frequency", &freq))
> + arch_timer_rate = freq;

Have you documented the bindings for this thing?

> + arch_timer_calibrate();

Why is the ability to get this from a clk not contemplated?
I think this will be common. You could make it optional I think,
just like in the SMP TWD.

> diff --git a/include/clocksource/arm_generic.h b/include/clocksource/arm_generic.h
> new file mode 100644
> index 0000000..6933f8e
(...)
> +#ifndef __ASM_ARCH_TIMER_H
> +#define __ASM_ARCH_TIMER_H

This #ifdef name looks confusing, what about
#ifndef __CLKSOURCE_ARM_GENERIC_H?

I noticed you already saw the problem with naming it "arch timers"
and renamed it to "arm generic" so a leftover here :)

Yours,
Linus Walleij


\
 
 \ /
  Last update: 2012-07-12 03:01    [W:0.628 / U:0.088 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site