lkml.org 
[lkml]   [2012]   [Jun]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 5/6 v5] deal with guest panicked event accoring to -onpanic parameter
At 06/27/2012 10:39 PM, Jan Kiszka Wrote:
> On 2012-06-27 09:02, Wen Congyang wrote:
>> When the guest is panicked, it will write 0x1 to the port KVM_PV_PORT.
>> So if qemu reads 0x1 from this port, we can do the folloing three
>> things according to the parameter -onpanic:
>> 1. emit QEVENT_GUEST_PANICKED only
>> 2. emit QEVENT_GUEST_PANICKED and pause the guest
>> 3. emit QEVENT_GUEST_PANICKED and poweroff the guest
>> 4. emit QEVENT_GUEST_PANICKED and reset the guest
>>
>> Note: if we emit QEVENT_GUEST_PANICKED only, and the management
>> application does not receive this event(the management may not
>> run when the event is emitted), the management won't know the
>> guest is panicked.
>>
>> Signed-off-by: Wen Congyang <wency@cn.fujitsu.com>
>> ---
>> kvm-all.c | 101 +++++++++++++++++++++++++++++++++++++++++++++++++++++++
>> kvm-stub.c | 9 +++++
>> kvm.h | 3 ++
>> qemu-options.hx | 15 ++++++++
>> vl.c | 10 +++++
>> 5 files changed, 138 insertions(+), 0 deletions(-)
>>
>> diff --git a/kvm-all.c b/kvm-all.c
>> index f8e4328..9494dd2 100644
>> --- a/kvm-all.c
>> +++ b/kvm-all.c
>> @@ -19,6 +19,8 @@
>> #include <stdarg.h>
>>
>> #include <linux/kvm.h>
>> +#include <linux/kvm_para.h>
>> +#include <asm/kvm_para.h>
>>
>> #include "qemu-common.h"
>> #include "qemu-barrier.h"
>> @@ -32,6 +34,9 @@
>> #include "bswap.h"
>> #include "memory.h"
>> #include "exec-memory.h"
>> +#include "iorange.h"
>> +#include "qemu-objects.h"
>> +#include "monitor.h"
>>
>> /* This check must be after config-host.h is included */
>> #ifdef CONFIG_EVENTFD
>> @@ -1931,3 +1936,99 @@ int kvm_on_sigbus(int code, void *addr)
>> {
>> return kvm_arch_on_sigbus(code, addr);
>> }
>> +
>> +/* Possible values for action parameter. */
>> +#define PANICKED_REPORT 1 /* emit QEVENT_GUEST_PANICKED only */
>> +#define PANICKED_PAUSE 2 /* emit QEVENT_GUEST_PANICKED and pause VM */
>> +#define PANICKED_POWEROFF 3 /* emit QEVENT_GUEST_PANICKED and quit VM */
>> +#define PANICKED_RESET 4 /* emit QEVENT_GUEST_PANICKED and reset VM */
>> +
>> +static int panicked_action = PANICKED_REPORT;
>> +
>> +static void kvm_pv_port_read(IORange *iorange, uint64_t offset, unsigned width,
>> + uint64_t *data)
>> +{
>> + *data = (1 << KVM_PV_FEATURE_PANICKED);
>> +}
>> +
>> +static void panicked_mon_event(const char *action)
>> +{
>> + QObject *data;
>> +
>> + data = qobject_from_jsonf("{ 'action': %s }", action);
>> + monitor_protocol_event(QEVENT_GUEST_PANICKED, data);
>> + qobject_decref(data);
>> +}
>> +
>> +static void panicked_perform_action(void)
>> +{
>> + switch (panicked_action) {
>> + case PANICKED_REPORT:
>> + panicked_mon_event("report");
>> + break;
>> +
>> + case PANICKED_PAUSE:
>> + panicked_mon_event("pause");
>> + vm_stop(RUN_STATE_GUEST_PANICKED);
>> + break;
>> +
>> + case PANICKED_POWEROFF:
>> + panicked_mon_event("poweroff");
>> + exit(0);
>> + break;
>> + case PANICKED_RESET:
>> + panicked_mon_event("reset");
>> + qemu_system_reset_request();
>> + break;
>> + }
>> +}
>> +
>> +static void kvm_pv_port_write(IORange *iorange, uint64_t offset, unsigned width,
>> + uint64_t data)
>> +{
>> + if (data == KVM_PV_PANICKED) {
>> + panicked_perform_action();
>> + }
>> +}
>> +
>> +static void kvm_pv_port_destructor(IORange *iorange)
>> +{
>> + g_free(iorange);
>> +}
>> +
>> +static IORangeOps pv_io_range_ops = {
>> + .read = kvm_pv_port_read,
>> + .write = kvm_pv_port_write,
>> + .destructor = kvm_pv_port_destructor,
>> +};
>> +
>> +#if defined(KVM_PV_PORT)
>> +void kvm_pv_port_init(void)
>> +{
>> + IORange *pv_io_range = g_malloc(sizeof(IORange));
>> +
>> + iorange_init(pv_io_range, &pv_io_range_ops, KVM_PV_PORT, 1);
>> + ioport_register(pv_io_range);
>
> This modeling is still not ok. We don't open-code ports anymore, we
> introduce devices. And this doesn't belong inro generic code as it is

Do you mean introducing a new device instead of I/O port?

Thanks
Wen Congyang

> x86-only. Will avoid that #ifdef as well.
>
> Thanks
> Jan
>



\
 
 \ /
  Last update: 2012-06-28 04:01    [W:1.667 / U:1.236 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site