lkml.org 
[lkml]   [2012]   [Feb]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH] USB: debugging code shouldn't alter control flow
Date
On Thu, 2 Feb 2012 15:38:14 -0500 (EST), Alan Stern <stern@rowland.harvard.edu> wrote:

> - urb->transfer_flags &= allowed;
> + allowed &= urb->transfer_flags;

Minor bikeshed here, but 'allowed' is not the right name for the value
at this point; perhaps just

/* warn if submitter gave bogus flags */
if ((urb->transfer_flags & allowed) != urb->transfer_flags)

might be better?

Otherwise, this looks nice to me.

Acked-by: Keith Packard <keithp@keithp.com>

--
keith.packard@intel.com
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2012-02-04 16:51    [W:0.049 / U:0.104 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site