[lkml]   [2012]   [Dec]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH v2 4/5] page_alloc: Make movablecore_map has higher priority
Hi Liu, Wu,

On 12/06/2012 10:26 AM, Jiang Liu wrote:
> On 2012-12-6 9:26, Tang Chen wrote:
>> On 12/05/2012 11:43 PM, Jiang Liu wrote:
>>> If we make "movablecore_map" take precedence over "movablecore/kernelcore",
>>> the logic could be simplified. I think it's not so attractive to support
>>> both "movablecore_map" and "movablecore/kernelcore" at the same time.

Thanks for the advice of removing movablecore/kernelcore. But since we
didn't plan to do this in the beginning, and movablecore/kernelcore are
more user friendly, I think for now, I'll handle DMA and low memory
address problems as you mentioned, and just keep movablecore/kernelcore
in the next version. :)

And about the SRAT, I think it is necessary to many users. I think we
should provide both interfaces. I may give a try in the next version.

Thanks. :)

 \ /
  Last update: 2012-12-09 09:41    [W:0.225 / U:1.580 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site