[lkml]   [2012]   [Dec]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC PATCH 01/11] Add hotplug.h for hotplug framework
On Wed, 2012-12-12 at 15:53 -0800, Greg KH wrote:
> On Wed, Dec 12, 2012 at 04:17:13PM -0700, Toshi Kani wrote:
> > Added include/linux/hotplug.h, which defines the hotplug framework
> > interfaces used by the framework itself and handlers.
> No, please name this properly, _everything_ is hotpluggable these days,
> and unless you want the whole kernel and all busses and devices to use
> this, then it needs to be named much better than this, sorry.
> We went through this same issue over 10 years ago, please, let's learn
> from our mistakes and not do it again.

Agreed. I will come up with a better name to avoid the confusion.

> > +/* Add Validate order values */
> > +#define HP_ACPI_BUS_ADD_VALIDATE_ORDER 0 /* must be first */
> This is really ACPI specific, so why not just put it under include/acpi/
> instead?

Yes, this needs to be revisited. For now, it is defined in the same
file since it helps to manage the ordering when all values are defined
in a same place. We may need the ordering values defined in each arch
when this framework is used by multiple architectures.

> And note, PPC and other arches probably do this already (s390?) so to
> exclude them from the beginning would not be a good idea.

Thanks for the suggestion. I will check other architectures and bring
them to the discussions.


 \ /
  Last update: 2012-12-13 05:41    [W:0.049 / U:5.456 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site