Messages in this thread Patch in this message |  | | Date | Sat, 3 Nov 2012 02:19:09 -0700 | From | "Paul E. McKenney" <> | Subject | Re: [PATCH v2 6/9] rcu: use __this_cpu_read helper instead of per_cpu_ptr(p, raw_smp_processor_id()) |
| |
On Fri, Nov 02, 2012 at 08:19:04PM +0000, Christoph Lameter wrote: > On Fri, 2 Nov 2012, Paul E. McKenney wrote: > > > On Sat, Nov 03, 2012 at 12:01:47AM +0800, Shan Wei wrote: > > > From: Shan Wei <davidshan@tencent.com> > > > > > > Signed-off-by: Shan Wei <davidshan@tencent.com> > > > --- > > > kernel/rcutree.c | 2 +- > > > 1 files changed, 1 insertions(+), 1 deletions(-) > > > > > > diff --git a/kernel/rcutree.c b/kernel/rcutree.c > > > index 74df86b..441b945 100644 > > > --- a/kernel/rcutree.c > > > +++ b/kernel/rcutree.c > > > @@ -1960,7 +1960,7 @@ static void force_quiescent_state(struct rcu_state *rsp) > > > struct rcu_node *rnp_old = NULL; > > > > > > /* Funnel through hierarchy to reduce memory contention. */ > > > - rnp = per_cpu_ptr(rsp->rda, raw_smp_processor_id())->mynode; > > > + rnp = __this_cpu_read(rsp->rda->mynode); > > > > OK, I'll bite... Why this instead of: > > > > rnp = __this_cpu_read(rsp->rda)->mynode; > > Because this_cpu_read fetches a data word from an address. The addres is > relocated using a segment prefix (which contains the offset of the > current per cpu area). > > And the address needed here is the address of the field of mynode > within a structure that has a per cpu address.
OK, I do understand why it happens to work. My question is instead why it is considered a good idea. After all, it is the ->rda field that is marked __percpu, not the ->mynode field. So in the interest of mechanical checking and general readability, it seems to me that it would be way better to apply __this_cpu_read() to rsp->rda rather than to rsp->rda->mynode.
Thanx, Paul
|  |