lkml.org 
[lkml]   [2012]   [Nov]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 06/43] mm: numa: Make pte_numa() and pmd_numa() a generic implementation

* Mel Gorman <mgorman@suse.de> wrote:

> That said, your approach just ends up being heavier. [...]

Well, it's more fundamental than just whether to inline or not
(which I think should be a separate optimization and I won't
object to two-instruction variants the slightest) - but you
ended up open-coding change_protection()
via:

change_prot_numa_range() et al

which is a far bigger problem...

Do you have valid technical arguments in favor of that
duplication?

If you just embrace the PROT_NONE reuse approach of numa/core
then 90% of the differences in your tree will disappear and
you'll have a code base very close to where numa/core was 3
weeks ago already, modulo a handful of renames.

It's not like PROT_NONE will go away anytime soon.

PROT_NONE is available on every architecture, and we use the
exact semantics of it in the scheduler, we just happen to drive
it from a special worklet instead of a syscall, and happen to
have a callback to the faults when they happen...

Please stay open to that approach.

Thanks,

Ingo


\
 
 \ /
  Last update: 2012-11-16 19:41    [W:0.108 / U:0.032 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site