lkml.org 
[lkml]   [2012]   [Oct]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v4 9/9] bug.h: Convert BUILD_BUG{,_ON} to use BUILD_BUG_ON_MSG
On Sun, Oct 28, 2012 at 03:57:15PM -0500, danielfsantos@att.net wrote:
> Remove duplicate code by converting BUILD_BUG and BUILD_BUG_ON to just
> call BUILD_BUG_ON_MSG. This not only reduces source code bloat, but
> also prevents the possibility of code being changed for one macro and
> not for the other (which was previously the case for BUILD_BUG and
> BUILD_BUG_ON).
>
> Signed-off-by: Daniel Santos <daniel.santos@pobox.com>
> ---
> include/linux/bug.h | 17 +++--------------
> 1 files changed, 3 insertions(+), 14 deletions(-)
>
> diff --git a/include/linux/bug.h b/include/linux/bug.h
> index 3bc1ddf..b58ba51 100644
> --- a/include/linux/bug.h
> +++ b/include/linux/bug.h
> @@ -81,14 +81,8 @@ struct pt_regs;
> #ifndef __OPTIMIZE__
> #define BUILD_BUG_ON(condition) __compiletime_error_fallback(condition)
> #else
> -#define BUILD_BUG_ON(condition) \
> - do { \
> - extern void __build_bug_on_failed(void) \
> - __compiletime_error("BUILD_BUG_ON failed"); \
> - __compiletime_error_fallback(condition); \
> - if (condition) \
> - __build_bug_on_failed(); \
> - } while(0)
> +#define BUILD_BUG_ON(condition) \
> + BUILD_BUG_ON_MSG(condition, "BUILD_BUG_ON failed: " #condition)

Concatenating "condition" might not be very informative in all cases.
For example:

BUILD_BUG_ON(1);

Having __LINE__ is good enough IMHO.

Thanks.

--
Regards/Gruss,
Boris.


\
 
 \ /
  Last update: 2012-10-30 21:01    [W:0.382 / U:0.144 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site