lkml.org 
[lkml]   [2012]   [Oct]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject[PATCH tip/core/rcu 0/7] CPU hotplug changes for 3.8
Hello!

This patch series provides further updates to RCU's interaction with
CPU hotplug. The individual patches are as follows:

1. Fix an obsolete comment describing ->onofflock.
2. Make rcutorture print the errno from cpu_down() failure if
the "verbose" module parameter is specified.
3. Make _cpu_down() use stop_cpus() instead of __stop_machine().
4. Rename ->onofflock to ->orphan_lock to correctly indicate this
lock's current scope.
5. Avoid counter wrap in synchronize_sched_expedited().
6. Move synchronize_sched_expedited() from global variables to
the rcu_state structure.
7. Instrument synchronize_rcu_expedited() for debugfs tracing.

Thanx, Paul

b/kernel/cpu.c | 9 ++-
b/kernel/rcutorture.c | 9 +++
b/kernel/rcutree.c | 4 -
b/kernel/rcutree.h | 7 +-
b/kernel/rcutree_plugin.h | 3 -
kernel/rcutree.c | 112 ++++++++++++++++++++++++++++++----------------
kernel/rcutree.h | 12 ++++
7 files changed, 108 insertions(+), 48 deletions(-)



\
 
 \ /
  Last update: 2012-10-30 18:41    [W:0.062 / U:0.100 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site