lkml.org 
[lkml]   [2012]   [Oct]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    From
    Subject[PATCH 22/23] radio-wl1273: Replace memcpy with struct assignment
    Date
    This kind of memcpy() is error-prone. Its replacement with a struct
    assignment is prefered because it's type-safe and much easier to read.

    Found by coccinelle. Hand patched and reviewed.
    Tested by compilation only.

    A simplified version of the semantic match that finds this problem is as
    follows: (http://coccinelle.lip6.fr/)

    // <smpl>
    @@
    identifier struct_name;
    struct struct_name to;
    struct struct_name from;
    expression E;
    @@
    -memcpy(&(to), &(from), E);
    +to = from;
    // </smpl>

    Signed-off-by: Peter Senna Tschudin <peter.senna@gmail.com>
    Signed-off-by: Ezequiel Garcia <elezegarcia@gmail.com>
    ---
    drivers/media/radio/radio-wl1273.c | 3 +--
    1 files changed, 1 insertions(+), 2 deletions(-)

    diff --git a/drivers/media/radio/radio-wl1273.c b/drivers/media/radio/radio-wl1273.c
    index 9b0c9fa..6e55e93 100644
    --- a/drivers/media/radio/radio-wl1273.c
    +++ b/drivers/media/radio/radio-wl1273.c
    @@ -2084,8 +2084,7 @@ static int __devinit wl1273_fm_radio_probe(struct platform_device *pdev)
    }

    /* V4L2 configuration */
    - memcpy(&radio->videodev, &wl1273_viddev_template,
    - sizeof(wl1273_viddev_template));
    + radio->videodev = wl1273_viddev_template;

    radio->videodev.v4l2_dev = &radio->v4l2dev;

    --
    1.7.4.4


    \
     
     \ /
      Last update: 2012-10-27 09:01    [W:4.242 / U:0.124 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site